Selezione gruppi con nome


#1

Salve,
Premetto che sto usando la versione italiana di Rhino 5
quando tento di selezionare un gruppo con il comando SelGroup mi appare la finestra con l’elenco dei gruppi. fin qui tutto ok ma se utilizzo il pulsante “seleziona” della finestra, questo non mi permette di fare alcuna selezione di gruppi e di conseguenza non posso identificarte il gruppo se non ne conosco il nome. E’ un bug?
Con il comando SelName che mi sembra abbia caratteristiche analoghe invece tutto funziona a meraviglia.
Qualcuno mi sa rispondere?
Saluti Sergio Bonvini


#2

Ti manca un pezzo Sergio… :smiley:
Per fare quello che vuoi i gruppi devi prima nominarli con _SetGroupName.
In difetto di ciò i gruppi vengono nominati con nomi di default…Group01…Group02… non ho idea se questo venga tradotto in italiano in Gruppo01…etc


#3

Giuseppe i gruppi che ho creato li ho nominati uno a uno ma ciò nonostante il comando non funziona


#4

comunque non credo che il problema stia nel nome in quanto Rhino assegna automaticamente un nome al gruppo .
Il problema sta nel fatto che Rhino non mi permette di selezionare dal modello un gruppo di questo restituirmene il nome nell’elenco. Ho fatto l’esempio di seleziona oggetti per nome perchè immagino che il comando funzioni con caratteristiche analoghe. Se infatti nella finestra clicchi “seleziona” la finestra sparisce temporaneamente e Rhino ti consente di selezionare un oggetto che, se è in elenco, viene evidenziato. Immagino che così dovrebbe funzionare anche con i gruppi., solo che nel momento in cui clicchi seleziona , rhino non ti fa procedere. Spero di essermi spiegato :wink:


#5

Ciao Sergio
Qui funziona V5 SR11
Ciao Vittorio


#6

che dire… anche io ho la stessa versione. Evidentemente mi si è incasinato qualcosa. Proverò a reinstallare rhino anche se temo di perdere le mie macro e i miei tasti personalizzati.
Grazie comunque


#7

Quando hai selezionato premi OK e non select
Ciao Vittorio


#8

Vittorio, lancio il comando SelGroup

mi appare l’elenco dei miei gruppi. A questo punto vorrei selezionare dal modello un gruppo per sapere come si chiama pertanto clicco su “seleziona”. E qui rhino si ferma facendo il classico “plink” di errore.Con seleziona oggetto con nome seguendo questa procedura che ho descritto, sparisce per il tempo della selezione la finestra come da immagine e poi , fatta la selezione, ricompare con evidenziati i nome degli oggetti selezionati.
Se clicco Ok come mi hai suggerito, vale il contrario e cioè mi fa vedere nel modello quali sonoi gruppi che ho scelto dall’elenco e non è ciò che voglio.


#9

Può darsi che il comando SelGroup e il comando SelName non operino con lo stesso criterio, anche se mi pare strano. Ciò comunque di cui ho bisogno è poter selezionare un gruppo dal modello e sapere come si chiama.


#10

Aggiungo questa piccola curiosità
Succede anche a voi?

questo è ciò che accade se allungo la finestra


Il bottone seleziona è sparito


#11

Questo del bottone che sparisce non torna.
Che SR stai usando Sergio?


#12

Versione 5 SR11


#13

anche che non si possa selezionare il gruppo non torna