Cant connect to mcneel api!

Greetings, I’m having trouble connecting with mcneels licensing service, it appears that i simply cannot connect with rhino’s api. checking the website i can confirm it doesnt load. I have already turned off the firewall to no effect,

Any idea on how can i solve this? Thanks for any help

Hi there. requires ports 443 specifically to be accessible to Rhino.
Is this something you are experiencing recently?
Can you provide some more in depth information?

It appears to be recent, since i tried to release a license from my pc and turn it into a cloud license, the server doesnt get the update that it has been released from the pc, thats when i realized

Ive tried some method to know if the port is open but not completely sure on how to operate on that regard

I could check out your previous Rhino 7 eval license from the pc. Please try now.

Not connecting to the server still, in the server it appears that the license is on my pc but even if I release it from here it wont update in the server!

Just checked the database. Your RH80- license is ready to assign.
Try to access: and place the license in the license page.
Is this working so far?

Working now, thank you so much!

1 Mi Piace

Feliz Navidad!