Make2D - non si apre la tendina opzioni

Buongiorno,
Ho un problema con il comando make2D. Quando cerco di fare una messa in tavola il Rhino mi chiede di selezionare l’oggetto. Lo seleziono e premo invio come richiesto.
A questo punto dovrebbe aprirsi un menù a tendina in cui selezionare varie opzioni, bene, a me non si apre. Ovviamente non aprendosi il menù Rhino non mi disegna niente. Come
posso risolvere?

Grazie mille in anticipo.

Ciao Marty,
nella barra di comando non riporta alcun messaggio? (dopo la richiesta di selezione intendo)
Nel caso, prova a richiamare il comando con il trattino e underscore davanti (il trattino meno serve per bypassare la finestra delle opzioni e l’underscore serve per richiamare il comando in inglese):
-_Make2d
Ti appaiono le opzioni nella riga di comando?
Hai riscontrato solo questa anomalia o ci sono altre cose che non funzionano bene?
Puoi fare un systeminfo e copiare qui il risultato così da vedere se c’è qualche informazione utile?

-_Make2D funziona e mi proietta tutte e tre le viste. Il problema sembra essere solo il menù delle opzioni che non si apre.
Per ora mi sembra l’unico vero bug che ho trovato, i menù di altre funzioni come l’analisi dei bordi e delle superfici si aprono senza problemi e funzionano.
Intanto ti ringrazio, non so ancora come far riapparire il menù ma almeno posso usare la funzione make2D, posso cavarmela con a stringa di comando XD

In assenza di altre informazioni (come ad esempio il _systeminfo) risulta difficile capire cosa possa causare l’anomalia.
Controlla di avere l’ultima versione di Rhino (nelle opzioni trovi la sezione Updates and Statistics dove puoi verificare se ci sono aggiornamenti) oppure puoi provare a riparare il programma andando nelle opzioni di Windows → App → Rhino7 → Modifica → Ripara
Se serve altro siamo qua.
Ciao

Ho aggiornato Rhino ma ho ancora lo stesso problema.
Posto di seguito il Systeminfo

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03001, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)
License type: Evaluation, build 2021-04-10
License details: Stand-Alone
Expires on: 2021-06-30

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [64% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 3-10-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.92
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-10-2021
Driver Version: 27.21.14.6192
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21100.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Per prima cosa, prova a scaricare i driver aggiornati per la scheda video Intel 630 (quelli che hai sono dell’anno scorso ed è meglio averli aggiornati).

Poi, se non si risolve, proviamo ad avviare in safe mode.

Ciao,
Vai nel menu Opzioni → Plugins e accertati che i plugin indicati nella immagine che segue siano effettivamente attivi (segno di spunta presente)

Altra cosa: sarebbero utili gli screen capture della riga di comando mentre esegui il make2D

Ho aggiornato i driver e ho ancora il problema.
Confermo che i plug-in sono attivi e con la spunta.
La riga di comando dice semplicemente:

Comando: _Make2D
Selezionare gli oggetti da mettere in tavola
Selezionare gli oggetti da mettere in tavola. Premere Invio al termine

Quando premo invio non succede nient’altro. Con -_make2D invece funziona tutto.

Rhino non sta usando la scheda dedicata ma continua a usare quella integrata come primaria.
Prova a disabilitare la scheda integrata dalla gestione risorse o seguire il post specifico su questo tema:Rhino 7: crash in avvio o problemi di visualizzazione

Detto questo usa la procedura che ti ha indicato Lucio: da pannello di controllo vai su Rhino 7 e tasto destro Modifica e Ripara.