Rhino 7: crash in avvio o problemi di visualizzazione

Rhino 7 fa un uso molto spinto dello standard OpenGL per tutto quello che riguarda la visualizzazione.
Rhinoceros e la scheda video “dialogano” attraverso i driver della scheda.
Lo standard OpenGL si evolve e occorre adeguarsi. Tenere aggiornati i driver video è la prima regola per fare in modo che Rhino funzioni come atteso.
Se usate una scheda NVidia, questo il posto per cercare driver recenti.

Cosa fare in caso di crash in avvio o problemi di visualizzazione.
Se avete un computer fisso:
Controllate che il cavo che collega computer e monitor sia collegato (lato computer) a una delle prese della scheda video e non alla scheda madre.
Aggiornate i driver della scheda video
Molte schede madri hanno scheda integrata (esempio Intel HD 630…) accertatevi che anche questi driver siano aggiornati.
Se Rhino non parte o crasha in avvio provate ad avviare usando il programma (lo trovate nell’elenco di tutti i programmi installati) Rhinoceros 7 in modalità sicura.
Questa versione di Rhino non è per lavorare ma per diagnostica. Una volta avviato, digitando il comando: _SystemInfo (invio) verrà prodotto un testo. Consultate la sezione: “Primary Display…” che indica quale scheda viene usata come primaria. Deve essere indicata, come primaria, la scheda video dedicata (es: Nvidia…) e non la scheda video integrata (es: Intel HD…) Troverete anche indicazioni sulle date dei driver che state attualmente usando. Come linea di massima, driver più vecchi di 6 mesi per una scheda dedicata dovrebbero essere un limite.
Windows 10 permette di selezionare, per ogni programma quale scheda video usare. Se volete impostare la scheda da usare per Rhinoceros, indicherete la scheda video dedicata.

Se questo messaggio ha risolto il problema vi pregherei di mettere un like semplicemente per permetterci di conteggiare e valutare quanto impatta sull’uso di Rhino.

Grazie.

3 Mi Piace

Procedura per assegnare una determinata scheda video ad una applicazione.
In presenza di più schede video installate nello stesso PC, può capitare che Windows utilizzi per Rhino quella meno performante (con conseguenti rallentamenti delle prestazioni).
Per evitare ciò, possiamo forzare Windows ad utilizzare una specifica risorsa video:

Apriamo le Impostazioni di windows - Sistema - Schermo - Ultima voce “Impostazioni Grafica”

Nella parte bassa della scheda “impostazioni grafica” c’è una sezione “Preferenza prestazioni grafiche”.
Dal menù a tendina selezioniamo “Applicazione Desktop” e successivamente clicchiamo sul tasto “SFOGLIA”.
Nella finestra di gestione risorse che si aprirà andremo a selezionare l’eseguibile dell’applicazione che vogliamo aggiungere (ad esempio, se vogliamo selezionare Rhino V7, andremo in “C:\Program Files\Rhino 7\System\Rhino.exe”) e clicchiamo sul pulsante “Aggiungi”.

Una volta definita l’applicazione, la vedremo apparire in un elenco in fondo alla finestra.
Selezioniamo l’applicazione, clicchiamo sul pulsante “Opzioni” e si aprirà una finestra con le varie configurazioni video disponibili (di default l’opzione è settata su “Lascia la scelta a Windows”).
Selezioniamo la scheda video con il tipo di prestazioni che ci interessa utilizzare e clicchiamo su “Salva”

La procedura è così conclusa.
Ai successivi avvii dell’applicazione, Windows utilizzerà le risorse video che abbiamo specificato.

4 Mi Piace

Grazie Lucio!!!

1 Mi Piace

Salve . purtroppo al momento di riaprire Rhino torna a prenderli la scheda meno performante .Grazie

Ciao Edoardo,
per poter analizzare il problema è necessario che lanci il comando _SystemInfo in Rhino e che incolli qui il risultato.

Invio …

Rhino 7 SR2 2020-12-8 (Rhino 7, 7.2.20343.11011, Git hash:master @ d3289272aab6acdf2cb6aaf1869cd9a2d8cb464c)
License type: Commerciale, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 7.9Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel® Iris™ Graphics 5100 (Intel) Memory: 1GB, Driver date: 8-8-2020 (M-D-Y). OpenGL Ver: 4.3.0 - Build 20.19.15.5166
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce GTX 850A (NVidia) Memory: 2GB, Driver date: 12-11-2020 (M-D-Y).
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

ATTENTION:
Desktop is using the slower, less reliable integrated graphics device and probably needs a configuration change.

There is only one monitor detected, but it’s connected to the slower, integrated graphics video port.

  • Recommended: Unplug the monitor and plug it into one of the video ports on this device:
    [NVIDIA GeForce GTX 850A]
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 20.19.15.5166
Driver Date: 8-8-2020
Driver Version: 20.19.15.5166
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.2.20343.11011
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.20343.11011
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.20343.11011
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.20343.11011
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.20343.11011
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

Prego controllare

Non so se hai un portatile o un PC normale…
Da quello che c’è scritto, devi collegare il monitor alla porta video della scheda Nvidia GTX850A…

Il mio è un Desktop e All-in-one PC , di 4 anni , è questo il problema se imposto la scheda Nvidia , quando apro Rhino 7 non la prende e ritorna con Intel . Grazie…

Quindi hai una sola porta video?
Al massimo, per capire, fai una foto al retro del pc così vediamo come è collegato il monitor…

impossibile se ha una scheda dedicata

Edoardo fai qualche foto del retro del tuo computer e indica dove sta il cavo che collega il monitor gentilmente

Mi fermo che sennò vengono fuori messaggi doppi… :stuck_out_tongue_winking_eye:

E’ tutto integrato vedi foto…

devi disabilitare da bios direi
P.S. mi dici il modello esatto del computer?

Quoto, riavvia, entri nel bios, disabiliti scheda video integrata.

Allego link della Lenovo per accedere al Bios

Grazie , Giuseppe , Lucio, provo e vi so dire…

Ho provato a disabilitare la scheda intel ,e rilanciando Rhino 7 prende la GeForce , tutto funziona molto bene soprattutto con li comando _paste è istantaneo ( con INTEL 12 secondi per l’incolla) . Purtroppo il video non si vede bene , problemi con i colori e non c’è molta definizione

1 Mi Piace

questo però potrebbe dipendere dai driver della GeForce. Hai controllato se ce ne sono di più aggiornati?