Problemi di visualizzazione


#1

Salve a tutti…sto lavorando alla tesi, ma Rhino per mac mi da un problema di visualizzazione…precisamente se creo delle superfici da delle polilinee o curve queste escono dal perimetro che viene creato…man mano che proseguo con il lavoro la situazione peggiora e le superfici diventano frastagliate…questo problema persiste anche quando vado a mettere la visualizzazione render e scompare se utilizzo la visualizzazione wireframe, ma è una falsa soluzione dato che poi i programmi di rendering tipo cinema mi impediscono di importare il file riconoscendone dei problemi…cosa devo fare??


#2


#3

Ciao,
ti avevo risposto anche dal supporto ma volentieri proseguo qui:
A che distanza sei dall’origine?

Qui non ci siamo… cioè non confondiamo mesh di visualizzazione con quella di export.
la cosa migliore è che alleghi un file con un dettaglio che crea problemi.


#4

Allego il file…il problema mi si manifesta in ogni vista.camminamento.3dm (771.1 KB)
sono distante dall’origine perché si tratta di linee importate da un file autocad…ovviamente pulito e per non avere problemi avevo fatto anche un proiezione su una superficie così da non dover lavorare su linee (magari fallate) di autocad


#5

ah aggiungo che le linee che ho importato son davvero poche ( e come già detto proiettate/messe in tavola 2D) il resto sono tutte linee nuove create da rhino…il problema si manifesta gradualmente, cominciando con piccole imperfezioni quasi impercettibili e aggravandosi sempre di più (come nell’istantanea allegata) man mano che proseguo con il lavoro…intanto grazie!


#6

Intanto BRAVO.
Nel senso che è il primo intervento di supporto tecnico ad un utente Mac che utilizza nel modo giusto il canale giusto e con descrizione giusta.
Sembri uno dei miei amici utenti … di vecchia data…
Su Rhino Win tutto ok. Nessuna distorsione. prova a fare una cosa: seleziona tutto e trascina in posizione 0,0 (origine) e verifica che la visualizzazione sia corretta.
Potrebbe trattarsi del “Far from origin” problem:
http://wiki.mcneel.com/rhino/farfromorigin

Ciao


#7

No mesh in doppia precisione per Mac ?
Ahi ahi ahi ahi ahi …
:slight_smile:


#8

ti ringrazio…ho provato come suggerito dalla spiegazione del link, anche se alcuni passaggi non mi sono molto chiari, però ad esempio già portandolo nell’origine senza copiare il file del modello, il risultato è migliore e mi permette (per ora) di importarlo in cinema4d, mantenendo comunque qualche piccolo problema tipo questo della foto…grazie per la pronta risposta!


#9

Prova a modificare le impostazioni di meshatura impostando una distanza del bordo mesh dalla superficie di 0.01 così da aumentare la triangolazione.
Vedi immagini.


#10

Sono due problemi diversi.
Quello del far-from-origin è una cosa, per questo ti ha risposto Lucio.


#11

Ok…credevo che uno fosse uno la conseguenza dell’altro perché ho notato che questa sorta di “bug” si presentava in forma minore (vedi la foto dell’ultimo post) per diventare successivamente come la cattura iniziale che ho mandato ad inizio discussione…come se iniziasse con una piccola imprecisione e degenerasse via via che il lavoro andava avanti. Per ora rimane la piccola imprecisione ma non degenera, spero davvero che fosse il far from origin!


#12

Grazie Lucio…mi sembra effettivamente migliorato anche se quando utilizzo molto lo zoom si ripresenta il problema in parte minore…avevo le mesh impostate su jagged e faster con densità a 0.65 e minimum initial grid quads a 16


#13

Purtroppo per superfici che presentano bordi con angoli molto acuti la creazione della mesh di visualizzazione non sarà mai perfetta a meno che tu non spinga i parametri a valori ancora più ristretti… a scapito della gestione delle risorse video…
Esiste comunque la possibilità di settare delle custom mesh per ogni oggetto (così aumenti la meshatura solo degli oggetti problematici e lasci gli altri leggeri).
Vedi immagini.
Ciao


#14

Grande! ti ringrazio, proverò a vedere che viene…comunque utilissimo questo forum! grazie anche a Giuseppe!