Rhinoceros non risponde

Salve, ho scaricato la versione prova di Rhinoceros 7 da Macbook pro, però mi da un sacco di problemi, è lentissimo si blocca e sono costretta a chiudere il programma praticamente ogni 3 comandi, ho provato a lanciare un render a bassa qualità con solo 2 texture di un oggetto semplice e dopo 11h ancora non era neanche a metà. Qualcuno sa come aiutarmi?

Ciao e benvenuta.
Avvia Rhino e nel box dove si scrivono i comandi, scrivi: _SystemInfo (invio)
Il programma produce un testo che dovresti copiare e incollare nella tua risposta.

1 Mi Piace

Grazie mille per avermi risposto, il problema è che adesso non riesco neanche più ad aprirlo ho anche provato a disinstallare il programma e re-installarlo ma nulla, carica soltanto senza aprire neanche un documento vuoto e dopo un pò mi esce il messaggio d’errore “Rhino non risponde”

ok sono riuscita a riaprirlo invio il testo:
Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05002, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Valutazione, build 2021-06-09
License details: Cloud Zoo
Expires on: 4468534-08-18

Apple Intel 64-bit macOS Versione 10.15.3 (Build 19D76) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro14,3
Language: it-IT (MacOS default)

AMD Radeon Pro 555 OpenGL Engine (OpenGL ver:4.1 ATI-3.5.5)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB
Graphics: Radeon Pro 555
Displays: LCD colori (258dpi 2x)

Graphics processors
Intel HD Graphics 630 (1536 MB)
Radeon Pro 555 (2 GB)
Color LCD (1680 x 1050)

USB devices
Seagate: Expansion
Apple Inc.: Apple T1 Controller
Apple Inc.: USB-C Digital AV Multiport Adapter

Bluetooth devices
Broadcom: Magic Mouse 2

Third party kernel extensions
None

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.7.21160.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.7.21160.5002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.7.21160.5002

Inserisco inoltre una schermata di cosa succede quando si blocca, il sistema informa che Rhino sta utilizzando 93 gb di memoria

Che strana data… una valutazione che cesserà nell’anno 4.468.534 si potrebbe definire “a vita”?

Vedo che Rhino ti parte a 93 GB di memoria occupata… questo succede a programma aperto senza nessun file o intanto che sta facendo il rendering?

1 Mi Piace

Per quanto riguarda la data non saprei che dirle sinceramente, per quanto riguarda i 93 GB di memoria succede mentre utilizzo il programma, ad esempio lo screen fatto riguarda il comando “messa in tavola 2D”. Ma è capitato anche con comandi tipo “copia”. Inoltre anche solo per muovermi nello spazio di lavoro ha bisogno di caricare.

Era una battuta… nulla di grave.

Questa, invece, è un’informazione importante.
Se Rhino, all’apertura, funziona normalmente (intendo partendo da un file di default vuoto) e degenera man mano che si sta lavorando, allora bisogna vedere quali oggetti creano il problema.
Non serve che siano oggetti di grandi dimensioni, basta che ci siano delle microsuperfici o dei bordi corrotti che impallano il mesher o l’intersector code e le risorse vengono esaurite.
Con che tolleranze stai lavorando?
Gli oggetti presenti nel file sono creati in Rhino o importati da altro software?
Gli oggetti sono molto distanti dall’origine del Piano di Costruzione?
Puoi postare un file di esempio dove Rhino si impalla? (un file piccolo, di pochi mega).

1 Mi Piace

Come faccio a sapere se ci sono superfici del genere? Come posso poi modificarle per farle diventare superfici semplici? devo rifarle da capo? e nel caso come faccio ad evitare di crearle?

In realtà non essendo molto esperta non ho mai impostato tolleranza, quindi sto lavorando con quelle di default credo (?)

Si gli oggetti sono stati tutti creati da Rhino

No non credo siano troppo distanti dal piano di costruzione

le allego il file è uno tra i più piccoli che ho (12 MB).
SEDIA ALBINI_01 .3dm (12,0 MB)

Ciao Alessia, questi due oggetti di sicuro portano problemi.

1 Mi Piace

Ok, quindi cosa posso fare per risolvere? e che comando uso per controllare gli oggetti? Perché mi capita spesso quindi suppongo che sulla maggior parte dei file che ho generato ci siano oggetti non validi. Come si evita di creare queste superfici?

Disegnarli correttamente.

_SelBadObjects oppure _Check selezionando i vari oggetti

Disegnandole correttamente. :wink:
Nei due “cilindri” ci sono superfici che non c’entrano molto, ti consiglierei di disegnarli di nuovo.
Se li osservi vedi anche a occhio che ci sono cose strane:

image

Li volevi disegnare pieni o cavi?

1 Mi Piace

Se vuoi cancella gli elementi difettosi e importa, nel tuo file, quello che ti serve.
Sedia tubi cavi.3dm (172,0 KB)
Sedia tubi pieni.3dm (149,2 KB)

1 Mi Piace

Perfetto grazie mille!!
Ultima domanda, come posso risolvere il problema dei render? anche impostando “qualità bozza” a 72 dpi ci mette delle ore e dopo aver aspettato 5/6 h per un render ovviamente viene malissimo…

non sono un esperto di mac, ma da quello che vedo nel System Info direi che il problema sta nella scheda grafica. Ho fatto una veloce ricerca sui benchmark e i risultati sono piuttosto lenti in fatto di velocità di rendering.

direi che è normale. Domanda: usi solo Rhino per il rendering o altri Sw? e se si, quali e ti danno gli stessi tempi?

Quindi per riuscire a fare dei render più veloci e a qualità migliori, dovrei optare per l’acquisto di una eGPU? non c’è altro modo? (magari meno dispendioso)

Si per il momento uso solo rhino, vorrei utilizzare un software di render ulteriore però non sono riuscita a trovarne uno compatibile con Mac. o meglio ho provato ad installare la versione prova di maxwell per capire come funzionasse e nel caso valutare l’acquisto ma non sono riuscita a renderizzare nulla perché quando provavo a fare i render da rhino in maxwell mi dava un errore e non mi faceva andare avanti.

Premessa la conferma che il problema principale è la scheda video e che quindi probabilmente ogni sw specifico per il rendering darà più o meno gli stessi risultati in termini di tempistica, se vuoi provare KeyShot questo è il link per richiedermi una demo full che lavora anche su mac.: KeyShot Demo - AUREASERVICE design studio
Giusto per capire se hai problemi con la tua scheda grafica. Va detto che ora KeyShot è ottimizzato per le RTX ma con Mac ha altri standard.

perfetto grazie mille!

1 Mi Piace