Fillet superfici e solidi


#1

ciao
purtroppo torno sull’argomento, evidentemente non riesco a digerirlo.
Innanzitutto vorrei che mi si chiarisse una cosa: l’unione tra due solidi porta inevitabilmente a creare uno spigolo nel punto di unione, immaginate per esempio due tubi intersecati, bene.
Come sono costruiti i tubi credo che poco importi, l’importante che risultino solidi, giusto?
la domanda è: perché quando si vuol fare un fillet sull’intersezione dei tubi, fillet superfici, si selezionano soltanto parti del tubo, cioè solo una parte della superficie totale del tubo? impetendo quindi il fillet, perché come sapete deve scegliere una prima superficie e una seconda sull’altro tubo, cosa in questo caso impossibile perché risultano divise.
Ho provato anche un’unione boleana ma fallisce.
grazie
Massimo


#2

In Rhino hai due tipi di fillet:

  1. quello fra superfici (non unite)
  2. quello che si fa su bordi uniti (bordi condivisi di una polisuperfice).

La parola “solido” in Rhino andrebbe sostituita da “polisuperficie chiusa”
il fillet su bordi uniti (2) non richiede unicamente polisuperfici chiuse.


#3

ciao Giuseppe
allego due esempi, tubi a sezione circolare e altri a sez pentagonale smussata, la prima il fillet riesce ma taglia non so perché una parte di tubo, l’altra è impossibile fare il fillet perchè come mostra la foto si selezionano soltanto le facce separate dal resto anche se sono solidi a tutti gli effetti
mi spieghi come mai e perché non si riesce a farlo?


#4

Prima si fa un’unione booleana e poi si fa il fillet edge (no fillet surface)


#5

okay ho provato e con l’unione va bene, purtroppo sul mio modello non riesco a fare l’unione, eppure sono tutti slidi che si interesecano


#6

allora ho scoperto che nel modello le estrusioni presenti anche se solidi, impediscono l’unione boleana. vi risulta?


#7

no.
senza modello è impossibile rispondere e capire cosa non funziona


#8

Hehe … quanto ottimismo ! :wink:

Direi … si prova a fare il FilledEdge … e se non funge si torna al FilletSrf … :smile:

… Scusate, non ho resistito …
:rofl:


#9

:rofl: hai ragione… mi sono dimenticato di aggiungere “con una buona dose di ottimismo”.


#10

ciao
ho modficato il modello e ora va bene, cerco di spiegarmi: avevo una polisuperficie che volevo “allungare” prima dell’unione boleana con il resto, fatto è che questi “allungamenti” ho docuto eliminarli perché erano loro la causa della non possibilità di unione, però ho fatto delle prove fuori dal modello ripetendo le operazioni, almeno come ricordavo, e l’unione è riuscita, forse perché ho replicato una situazione più semplice, non so.
comunque a posto
ciao
M