Oggetto "aperto"

Ciao ragazzi, sto cercando di capire se del seguente oggetto le superfici sono tutte chiuse. Il file è in Rhinoceros, ma l’oggetto l’ho esportato da Femap, il quale però non vede la superficie evidenziata in rosso come chiusa. Come faccio a verificare in Rhino che superiormente le forme siano tutte chiuse?

mcneel.3dm (644,4 KB)

Se selezioni l’oggetto, nella finestra delle proprietà ti dirà se hai selezionato una polisuperficie chiusa o aperta.
Per verificare quali spigoli della polisuperficie sono aperti puoi utilizzare il comando shownakededges.

ehm…trovo scritto solo “superficie”…

Vuol dire che è una singola superficie…
Fatti due prove… fai un cubo, una sfera, una superficie singola, un’estrusione aperta e vedi cosa ti restituisce quando li selezioni singolarmente.
Guarda anche nell’help il funzionamento di show naked edges.

Ho digitato il comando “shownakededges” sulla superficie di interesse (quella evidenziata in rosa) che in Femap non compare lasciando il vuoto. Però non ho capito come fare a chiuderla…

Allora, se vuoi imparare a usare rhino, non basta provare a caso il comando, devi dare un occhio all’help.
Nelle opzioni del comando devi selezionare bordi aperti per vedere solo i bordi che ti interessa individuare.
Se la superficie si seleziona da sola rispetto alle altre è ovvio che sia separata… bisogna fare un join…
Al momento ti sto rispondendo da cellulare quindi sono molto limitato nel poterti fare degli esempi al volo…

Ciao
In Rhino il tuo oggetto e’ composto da superfici indipendenti, non da polisuperfici/solidi.
In origine era cosi’ o erano dei solidi chiusi ( da quanto dici pare fossero forme chiuse ) ?
Con che formato hai esportato ?
Dal nome del layer seembra essere Iges e in Iges i solidi vengono scomposti nelle superfici componenti.
Comunque qualche problema in esportazione sembra esserci stato, dato che in Rhino risultano 4 ‘Bad objects’, vedi comando _SelBadObjects.
Se devi riavere i solidi originali dall’esportazione in Iges, devi nuovamente unire le superfici in Rhino con _Join, come ha detto Lucio.
Provando a riunire le superfici, ho visto che i problemi di esportazione sono piu’ gravi, ci sono altre superfici che sono da sistemare (nel pezzo grande, la tramoggia). Si vede anche (zoomando) perche’ i bordi della superfici sono disegnati fuori dalla superficie stessa.
Per correggere l’oggetto in Rhino, credo dovrai come minimo ‘ritrimmare’ alcune superfici. cioe’ eliminare il trim con _UnTrim, ricavare le curve di bordo in qualche modo, magari ridisegnandole da zero, e infine trimmare ( _Trim ) con le curve nuove. In questo modo le superfici dovrebbero risultare utilizzabili, alla fine le unisci con _Join, come gia’ detto.
( A volte questo non e’ sufficiente e si devono ridisegnare da capo alcune superfici, bisogna provare )
Se hai poca esperienza con Rhino, non e’ una cosa velocissima. Si tratta di lavorare ‘a basso livello’, cioe’ con curve e superfici, alla vecchia maniera se vogliamo. Rhino non ha problemi a fare queste cose. ma bisona conoscerlo un poco per potersi destreggiare con i vari comandi ecc.

Se ci sono problemi, fatti vivo. :slight_smile:
Ciao