AIUTO non mi si apre piu un file fatto con Rhino 6!

mi si apre ma subito scompare compare una finestra in inglese che chiede la mia email …
ci ho lavorato 1 giornata intera ieri…

cosa e’ successo ?

stamattina ho provato ad aggeggiare con le “istantanee” non con quel file …

ho disabilitato le "viste con nome " e le “istantanee” e ora mi si apre

La finestra ha l’aria di essere quella di un crash…
Avvia Rhino 6 e sulla linea di comando scrivi: _SystemInfo (invio) poi copia il contenuto prodotto dal comando.

Ho riprodotto il “CRASH” riabilitando sia le “VISTE CON NOME” sia le “istantanee” e immediatamante alla riapertura del file e’ ricomparsa la finestra ed il computer e’ uscito da Rhino

Poi ho aperto un altro rhino , ho disabilitato le " Viste con nome " e le " ISTANTANEE"c ed il file si e’ aperto normalmente, ho riabilitato le " viste con nome e’ ora sto’ lavorando

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Valutazione, build 2020-03-19
License details: Cloud Zoo. In use by: berepeppe ()
Expires on: 2020-07-01

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: BEPPEBERRETTI97

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-28-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 9-30-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.98

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2019
Driver Version: 26.21.14.3198
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

Beppe prova ad aggiornare i driver della scheda video perchè al momento Rhino sta usando come sistema primario di display la scheda integrata.
I driver li trovi qui:
https://www.nvidia.it/Download/driverResults.aspx/159230/it

no … non sta usando la scheda integrata
sono stato ben accorto …e anche nelle OPZIONI > OPENGL si legge Nvidia…

ho caricato questo driver che e’ quello con cui e’ stato venduto il pc
e quello che risulta piu nitido e piu veloce

anche stamattina all’apertura stessa storia…
si apre il file e subito dopo la finestra di crash…
non e’ bastato salvare un senza nome senza finestra delle viste aperta , ho anche dovuto riavviare il computer

Non è così Beppe.
Prova ad avviare in modalità sicura: da tutti i programmi di Windows vai su Rhino e scegli Rhino 6 in modalità sicura. Avviando in questo modo non carica molti plugin (ti avverte) e nemmeno l’OpenGL.
Se si avvia… abbiamo la quasi certezza.

viene fuori questa finestra
errore rhino in modalita' sicura

Beppe, mi confermi che questo messaggio ti è comparso avviando in Safe Mode?
Vorrei che a questo thread desse un occhio lo sviluppatore responsabile della grafica: Jeff.

si mi e’ comparso una volta caricato rhino in safe mode
lo confermo

Beppe ti mando il link a una versione che dovrebbe aver risolto il problema:
http://files.mcneel.com/dujour/exe/20200409/rhino_it-it_6.26.20100.01191.exe (italiano)
http://files.mcneel.com/dujour/exe/20200409/rhino_en-us_6.26.20100.01191.exe (inglese)

niente da fare … solita schermata
il system info e’ questo

Rhino 6 SR26 2020-4-9 (Rhino 6, 6.26.20100.01191, Git hash:master @ ca432935f4e84399332973e9ffef76084a21c4f5)
License type: Valutazione, build 2020-04-09
License details: Cloud Zoo. In use by: berepeppe ()
Expires on: 2020-07-01

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: BEPPEBERRETTI97

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-28-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 9-30-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.98

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2019
Driver Version: 26.21.14.3198
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.26.20100.1191
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.26.20100.1191
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.26.20100.1191
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.26.20100.1191
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Ricapitoliamo:
il problema è SOLO con quel file?
Nella stessa posizione del file dovresti averne uno con nome simile e suffisso .bak. Se lo rinomini con suffisso .3dm lo riesci ad aprire?

ho provato ad aprire il bak rinominato … mi si e’ aperto ma appena ho attivato le viste con nome mi e’ ricomparsa la finestra di crash…

non ho provato altri file … perche sto’ lavorando solo con quello sul momento…
provero’

ebbene si… tutti gli altri file ( ne ho provati 3) si aprano anche con le viste accese !!!

in effetti il bug e’ iniziato ad accadere solo dopo che ho provato le ISTANTANEE su quel file

con gli altri file non ho provato le istantanee